PAT甲级1086(算法笔记8.1DFS)

1086 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
			

Sample Output:

3 4 2 6 5 1
			
#include<iostream>//已知先序和中序,然后建树,然后后序遍历
#include<string>
#include<stack>
using namespace std;
const int maxn = 31;
struct node
{
    int id;
    node* lchild;
    node* rchild;
};
int pre[maxn], in[maxn];
int n;
node* create(int pl, int pr, int inl, int inr)//建树
{
    if (pl > pr)return NULL;
    node* root = new node;
    root->id = pre[pl];
    int k;
    for (k = inl; k <= inr; k++)
        if (in[k] ==pre[pl])
            break;
    int numl = k - inl;
    root->lchild = create(pl + 1, pl + numl, inl, k - 1);
    root->rchild= create(pl + numl+1, pr, k+1, inr);
    return root;
}
int num;
void postorder(node* root)
{
    
    if (root == NULL)return;
    postorder(root->lchild);
    postorder(root->rchild);
    printf("%d", root->id);
    num++;
    if(num!=n)
        printf(" ");
}
int main()
{
    string s;
    int x,prindex=0,inindex=0;
    stack<int>q;
    cin >> n;
    for (int i = 0; i < 2*n; i++)//出栈入栈共2n次
    {
        cin >> s;
        if (s == "Push")
        {
            cin>> x;
            q.push(x);
            pre[prindex++] = x;
        }
        else
        {
            x = q.top();
            in[inindex++] = x;
            q.pop();
        }
    }
    node*root=create(0, n - 1, 0, n - 1);
    postorder(root);
    return 0;
}

代码学习笔记 文章被收录于专栏

学习笔记,pat,牛客

全部评论

相关推荐

1 收藏 评论
分享
牛客网
牛客企业服务